I receive error code 1 when trying to start a Windows service of Yellowfin

Error code 1 usually occurs when a JVM of the wrong architecture is being used, i.e. 32-bit instead of 64-bit or vice-versa, and it should be easy enough to fix:

1) start up a Command Prompt (make sure you select the option “Run As Administrator”)


2) change directory to the bin folder of your Yellowfin installation

3) bring up the service properties dialogue by running the following command:

tomcat7w //ES//yellowfin (this is the name of your yellowfin service)


4) go to the Java tab and change the Java Virtual Machine setting to point to a JVM of different architecture than the current one. For example, if my service was initially using a 32-bit JVM you will note (x86) behind Program Files in the path:


5) Then change it to the 64-bit JVM (you may have to download and install it if you don’t have one):


Hopefully after that the service will start up without error. However, if you are still getting error code 1 then it would be worth removing the service and re-installing, and this is not hard to do, in the same Command Prompt that you were using above, just run the command:

service remove yellowfin

and then run the following command:

service install yellowfin

and then see if you can start the service, if not, then check the JVM and change it again.

If you are still having problems post or submit a ticket and one of our team will help. 

Is article helpful?